WordPress: Problema RSS Resuelto

Desde hace unos días el Feed RSS de jggweb no funciona. Me daba este mensaje de error:

Error de lectura XML: la instrucción de proceso XML no se encuentra al comienzo de una entidad externa
<?xml version=”1.0″ encoding=”ISO-8859-1″?>

Llevo varios días intentando resolver este problema.

He probado a:
- Desactivar los últimos plugins instalados.
- Desactivar todos los plugins.
- Quitar las líneas de código php de la barra lateral para ejecutar los plugins.
- He pasado a borrador todos los posts hasta el día que dejó de generar los feed correctamente.
- Instalado de nuevo el wordpress. Ya he aprovechado para instalar la 2.1.2.

Y con todas estas actuaciones no conseguí conseguí poner en funcionamiento este servicio.

Sergio de la Torre
me dio una pista: localizar espacios en blancos al principio o al final de los ficheros .php. Analicé el código fuente de todos los plugins que tengo instalados y… ¡bingo! en el plugin de getrandomlinks.php que uso para mostrar los enlaces favoritos de forma aleatoria en la barra lateral trás el ?> había un insignificante espacio en blanco que era el responsable de este problema. Lo eliminé y ya de nuevo los lectores RSS pueden acceder a jggweb.

Me alegro de que solucionaras, ya ves qué tontería puede hacer que algo no funcione. Aún así me sigue dando el mismo error ¿?

http://www.jggweb.com/feed/

Salu2

Conejín dice:

¡¡¡Hola, feliz finde y un Click!!!

IxcheL dice:

A mi me paso eso hace como mes y medio pero como desconozco totalmente de eso, solo me quedo esperar =( y se soluciono una semana después.

Me alegro que llegaras a una solución.

Saludos.

Ufff… esas cosas se escapan de mis “limitados conocimientos en páginas webs”, aunque algo debería ir aprendiendo…

Bueno, espero podáis disfrutar del eclipse de esta noche, e incluso sacar algunas fotillos… Yo al final creo que sólo lo disfrutaré relajado sin agobiarme con tiempos y foto, foto, foto…

Un abrazo y voto de hoy.

potaje.net dice:

Con Google Reader se leía tu feed perfectamente.
Ahora la pregunta es ¿Cómo ha llegado ese insignificante espacio en blanco al fichero php si suponemos que antes no estaba porque no había problemas en el feed?

Victor Silva dice:

Ya esta todo ok con el feed, de todas maneras les paso el dato a las personas que sindican con netvibes. Tienen que borrar la antigua ventana de sindicación y crear una nueva para que el feed cargue correctamente :)

Saludos!!

Pues que bueno que se ha solucionado; sin duda muchos lo agradecerán. Saludos.

Persio dice:

felicidades por el descubriemiento, yo recuerdo cuando empece con el lenguaje html me metia en cada lio, jejeje, saludos amigo y mi voto dominical!
nos leemos!

Muchas gracias a todos por vuestros comentarios.

nasturianu dice:

Ahora ya me funciona. La verdad es que es todo un mundo, porque un simple espacio en blanco que se cuela por ahi y ya te monta una de estas, y lo que es peor, que luego para encontrarlo puedes volverte loco…

Pedro dice:

Ya estamos aquí…. exprimiendo el Lunes… voto y saludos

Conejín dice:

Saludos de un lunes de febrero, y un voto de tu amigo conejín.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

*

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Switch to our mobile site